Mondoze Knowledge Base

Search our articles or browse by category below

My cPanel can’t load or keep logging me out after enabling Cloudflare?

Last modified: October 5, 2022
You are here:
Estimated reading time: 1 min

My cPanel can't Load or Keep Logging me out

Symptom:
You can try to access your cPanel behind Cloudflare and are finding that on the first page load that no images (or stylesheets or javascript) load – and, when trying to navigate to any link, you are immediately logged out. The experience is as if cPanel were broken in some way.

Cause:
cPanel has an option called “Cookie IP Validation”. This setting checks that the IP address that the visitor originally came from matches their IP address on subsequent requests. With Cloudflare, the IP address for requests to your server can variably come from any IP address in the list at https://www.cloudflare.com/ips

Resolution:

The solution is to access the cPanel server on a URL that doesn’t proxy through Cloudflare. Please use cPanel’s proxy subdomain URL http://cpanel.domain.com and have the DNS point directly to the cPanel server which is a default DNS setting.

Make sure this subdomain is not proxied through Cloudflare (not orange clouded).

Note: Starting with version 64 of WHM this is no longer an issue. Although it is possible that under some conditions this will still be noted. If this is the case please apply the solution above.

For further information, please Contact your hosting provider or cPanel support if you still see issues. 

Was this article helpful?
Dislike 0
Views: 572